Modifier

C'est le septième jour de mon calendrier sur WinDev®. J'espère que vous avez pu trouver au moins une astuce qui vous a été utile.

J'aime énormément travailler avec des tables ou des listes alimentés par des variables. Mais cela ne fonctionne pas pour les sélecteurs. Mais j'ai développé une petite fonction qui permet de simuler le comportement avec une fonction SélecteurAffiche.

Tout d'abord, il faut paramétrer le sélecteur pour qu'il retourne la valeur spécifiée par la Valeur Renvoyée de Option dans l'onglet Détail.

Et ensuite vous pouvez utiliser le code suivant :

PROCEDURE SélecteurAffiche(Sélecteur est un Champ, tDonnées est un tableau de stElement)

TANTQUE SélecteurOccurrence(Sélecteur) > 1
    SélecteurSupprime(Sélecteur, 1)
FIN

POUR TOUT UnElement DE tDonnées
    soit Indice = SélecteurAjoute(Sélecteur, UnElement:Libellé)
    Sélecteur[Indice]..ValeurRenvoyée = UnElement:Code
FIN

SélecteurSupprime(Sélecteur, 1)

Et un code exemple :

stElement est une Structure
    Code est une chaîne
    Libellé est une chaîne
FIN

tElements est un tableau de stElement = [["01", "Libellé 01"], ["02", "Libellé 02"], ["03", "Libellé 03"]]

SélecteurAffiche(Sélecteur1, tElements)

Et voilà, un sélecteur qui affiche le contenu d'un tableau. Libre à vous d'adapter le code pour aller encore plus loin.

Bonne journée à tous !

Article précédent Article suivant